Partial outage on Mexico - Movistar
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Oct 08, 2021 - 17:00 UTC
Investigating
We are currently investigating this issue.
Posted Oct 08, 2021 - 16:40 UTC
This incident affected: Mexico - Carriers / Operadoras (Mexico - Movistar).