Partial outage on Mexico - Telcel
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 19:33 UTC
Investigating
We are currently investigating this issue.
Posted Nov 10, 2021 - 18:50 UTC
This incident affected: Mexico - Carriers / Operadoras (Mexico - Telcel).