Partial outage on Mexico - Telcel
Incident Report for Sinch
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 18:03 UTC
Investigating
We are currently investigating this issue.
Posted Nov 09, 2021 - 17:43 UTC
This incident affected: Mexico - Carriers / Operadoras (Mexico - Telcel).